How to compile Starling Builder editor

We used IntelliJ IDEA as IDE and the project files are checked in. For other IDEs you need to create the project files yourselves.

IntelliJ

  • Intall AIR SDK 19+ and IntelliJ IDEA Ultimate Edition
  • Checkout the repo using:
    git clone https://github.com/yuhengh/starling-builder-editor --recursive
  • Open IntelliJ IDEA, goto File → Open, then point to the directory of the git repo
  • Goto File → Project Structure → SDKs, create a FLEX/AIR SDK named AIRSDK.
  • Goto Run → Edit Configurations, create a Flash App Run/Debug Configuration and choose the dev build config
  • Run the configuration just created

Flash Builder

  • Intall AIR SDK 19+ and Flash Builder 4.7
  • Checkout the repo using:
    git clone https://github.com/yuhengh/starling-builder-editor --recursive
  • Goto menu File → New → ActionScript Project, choose Desktop and select starling-builder-editor folder
  • Set the following ActionScript Build Path
Source pathsrc, starling-builder-engine/src, package
Library pathlibs
  • Right click src/starlingbuilder/editor/Main.as → Set as Default App
  • Launch the app

FlashDevelop

  • Intall AIR SDK 19+ and FlashDevelop
  • Checkout the repo using:
    git clone https://github.com/yuhengh/starling-builder-editor --recursive
  • Open FlashDevelop, Goto Project → New Project → AIR AS3 Projector, select starling-builder-editor folder
  • Set the following ActionScript Build Path (Right click folder in project tab and choose “Add Source Path” to set source path, right click folder in project tab and choose “Add To Library” to set library path)
Source pathsrc, starling-builder-engine/src, package
Library pathlibs
  • From project tab, right click src/starlingbuilder/editor/Main.as and select “Set Document Class”
  • Copy src/starlingbuilder/editor/Main-app.xml to the root folder, rename to application.xml to replace the generated one.
  • In application.xml, change the xmlns to match your AIRSDK version
  • Goto Project → Properties, set the output file to “bin\Main.swf” (this has to match the swf file name inside application.xml
  • Run the project

Build with Ant

  • Intall AIR SDK 19+ and Apache Ant
  • Checkout the repo using:
    git clone https://github.com/yuhengh/starling-builder-editor --recursive
  • open starling-builder-editor/buildscript/build.properties, change airsdk.root to point to your AIR sdk location. Windows user should also append .exe to property adl
  • cd buildscript and type ant to build
  builder/compile.txt · Last modified: 2018/02/12 05:46 by johannh
 
Powered by DokuWiki